Home Support Square Mixed content warning on HTTPS site

This topic contains 1 reply, has 2 voices, and was last updated by  jdacjohn 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4644

    urban_winter
    Participant

    I get “mixed content” warnings from Chrome now that I have switched my site to HTTPS. Some images are being requested as HTTP URLs, not HTTPS.

    The exact console message is:
    Mixed Content: The page at ‘https://juliabelldna.co.uk/’ was loaded over HTTPS, but requested an insecure image ‘http://juliabelldna.co.uk/wp-content/uploads/2017/02/looking-glass-918878_1920-e1486507387302.jpg’. This content should also be served over HTTPS.

    How can I fix this?

    I am not using the very latest version of the theme (Square Version: 1.3.4). Has this been fixed in a later version?

    #4654

    jdacjohn
    Participant

    I just wrote up an article on how to switch an existing WordPress site from HTTP to HTTPS. Basically what’s happening is that you applied that image to your site before you switched to HTTPS. Since the path to the image is stored in the WordPress database, when you applied it, it used your old site address from the general settings before you changed it from http:// to https://, and that’s what’s being pulled from the database when the page renders.

    The easiest way to fix this is to go into your appearances -> customize and change the image to something else (briefly) and publish the change. Visit your page and verify the mixed content is no longer being served, then change the image back to your desired image.

    From visiting your site, it appears that you have 3 images that are causing this issue. You can read more in the article here. The information you’re looking for will be close to the end of the article under the “Identifying Remaining Issues” heading.

    Hope this helps!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.