Home Support Total Home Section > Featured Section > Title/subtitle – translation problem

This topic contains 6 replies, has 3 voices, and was last updated by  HashThemes 3 days, 9 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4554

    edwinbin
    Participant

    Hi,

    I have installed Polylang and working on translating the site. However, I am not able to translate the Title/subtitle of the Featured Section under Home Section. I guess because that part I typed English directly in the fields. The same problem appears in other Sections such as the Service Section where I need to type directly there.

    I would much appreciate it if you could enlighten me on how to resolve this.

    Thank you and Happy New Year.

    • This topic was modified 2 weeks, 6 days ago by  edwinbin. Reason: Clarify the issue in the subject line
    #4558

    dvukosavljevic
    Participant

    I had the same problem, just on HashOne theme and I resolved it with Loco translate. Loco enables you to change the source text, so you can replace the texts that come with theme instalation in English and then translate it…

    Hope this will help….

    #4561

    edwinbin
    Participant

    Thank you so much for your reply. I tried Loco Translate. On the Editor screen I cannot find the Title / Sub-title nor the things that I typed. For example, in the English version I typed “Hello” as the Title, I cannot find the same “Hello” on the Editor screen for me to type the translation below. Maybe I have made some wrong assumptions as to how it should work? But I cannot find the Title / Sub-title field for me to type the translation.

    Sorry for so many questions… and thank you in advance.

    #4571

    dvukosavljevic
    Participant

    Hi edwinbin,

    sorry for a late reply. First of all you will need to have a clean theme installation, with no changes made. Here is how I solved this issue with Loco translate and PoEdit, translation files editor (get it for free on https://poedit.net/download ).

    When you log on your administration panel in WordPress, firstly go to Loco Translate menu Themes and select the them you want to translate. Then you will be able to Add new language or Edit template. In case that your language is not listed, I suggest that you first add your language. After that, please select Edit template.
    When you edit the template, you will be able to change headlines set in English in the field “Source text:”. When you change all the lines you want to change, please do not forget to Synchronize changes.

    When synchronization is completed, in the upper right corner, you will have an option to download POT file. Edit POT file with PoEdit application, check translation and upload it in the folder on your Cpanel administration: your domain – wp-content – languages – themes.

    I hope this will solve your problems as it solved mine. I just didn’t want bilingual issues to stop me from using HashThemes beautiful theme.

    #4573

    edwinbin
    Participant

    Hi dvukosavljevic,

    Thank you so much for your detailed response. Maybe I got into problem because I didn’t have a clean theme installation. I installed Loco Translate halfway into the website construction. Let me see what I can do. Thanks again for your reply. It is much appreciated!

    #4577

    dvukosavljevic
    Participant

    You are welcome edwinbin!
    I case you have additional issues, please do not hesitate to get in touch!
    Best regards

    #4631

    HashThemes
    Keymaster

    @edwinbin The text added from the customizer panel can not be translated. Only the post , pages added via customizer can be translated in to multi language.

    @dvukosavljevic is referring a process to translate the theme into the local language(only one language) but for multi language it requires some additional coding which the free theme does not have.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.